w3h5

Z-Blog后台无法安装、更新应用的解决方法

好久没更新东西了,今天登录后台发现要更新 应用中心,就点击更新了,但是更新后发现,无法更新和安装应用了。

其实是Z-Blog的应用中心更换了服务器,部分主机不能跟随跳转,导致出现错误,控制台报错如下:

http访问的情况下:

XMLHttpRequest cannot load http://lanjie.host.zzidc.ha.cn/404.html. Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://www.w3h5.com' is therefore not allowed access.

Z-Blog后台无法安装、更新应用的解决方法 经验总结 第1张

https访问的情况下:

Mixed Content: The page at 'https://www.w3h5.com/zb_users/plugin/AppCentre/main.php?method=check' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://lanjie.host.zzidc.ha.cn/404.html'. This request has been blocked; the content must be served over HTTPS.

Z-Blog后台无法安装、更新应用的解决方法 经验总结 第2张

前端显示如下,一直处于卡死状态

Z-Blog后台无法安装、更新应用的解决方法 经验总结 第3张

实际上,就算点击了 更新应用中心,还是没有解决问题,因为现在后台根本无法自动更新了。

所以我们需要去官网下载zba包,直达连接:https://app.zblogcn.com/?id=231

Z-Blog后台无法安装、更新应用的解决方法 经验总结 第4张

下载完成后,本地上传,会自动更新

Z-Blog后台无法安装、更新应用的解决方法 经验总结 第5张

更新完就可以正常安装、更新应用了。

Z-Blog后台无法安装、更新应用的解决方法 经验总结 第6张

赞 (2)
分享到: +More |

评论 沙发

换个身份