uni-app项目改用vue-cli npm运行报错及问题总汇

之前的一个 uni-app 项目,为了方便管理和自动化部署,准备采用 vue-cli 和 webpack 进行部署,遇到了一些问题,记录一下:

当然,如果你是刚开始创建项目,可以直接通过 vue-cli 进行创建: 用Vue CLI创建uni-app,摆脱HBuilder,npm命令行运行及发布

缺少模块:

Hbuilder 可以直接在插件中心进行插件安装,但是改用 vue-cli 之后有些就不能用了。下面是一些报错信息:

缺少 sass 加载组件:

Failed to resolve loader: sass-loader
You may need to install it.

解决方法:安装 sass-loader 依赖

npm 安装:

npm i sass-loader --save-dev

yarn 安装:

yarn add sass-loader --save-dev

缺少 less 加载组件:

Failed to resolve loader: less-loader
You may need to install it.

解决方法:安装 less-loader 依赖

npm 安装:

npm i less-loader --save-dev

yarn 安装:

yarn add less-loader --save-dev

缺少 sass 模块:

Error: Cannot find module 'sass'

解决方法:安装 sass 模块

npm 安装:

npm i sass --save-dev

yarn 安装:

yarn add sass --save-dev

缺少 less 模块:

Error: Cannot find module 'less'

解决方法:安装 less 模块

npm 安装:

npm i less --save-dev

yarn 安装:

yarn add less --save-dev

还有一个比较奇葩的报错:

Module build failed (from ./node_modules/sass-loader/dist/cjs.js):
SassError: File to import not found or unreadable: ../../styles/_variables.scss.
        on line 1 of src/styles/store_tpl.scss
        from line 851 of src/pages/index/store.vue
>> @import "../../styles/_variables.scss";

这个问题搞了半天,最后发现是在 a.sass import 引入了 b.sass 但是 b.sass 的路径不对,找不到这个文件,所以就报这个错误。

检查一下文件路径,看有没有问题,改成正确的就可以了。


未经允许不得转载:w3h5 » uni-app项目改用vue-cli npm运行报错及问题总汇

赞 (0)
分享到: +

评论 沙发

换个身份

  • 昵称 (必填)
  • 邮箱 (选填)