用Vue CLI创建uni-app,摆脱HBuilder,npm命令行运行及发布

除了 HBuilderX 可视化界面,也可以使用 cli 脚手架,可以通过 vue-cli 创建 uni-app 项目。

如果是老的项目,也可以通过下方步骤,创建一个 uni-app 选择默认模板,然后将项目原封不动的复制到新项目的 ./src 目录。

执行 npm run serve / npm run build 就可以运行和打包了。

老项目改用 Vue CLI 可能会遇到一些报错,可以参考这篇文章:uni-app项目改用vue-cli npm运行报错及问题总汇

环境安装

全局安装vue-cli

npm install -g @vue/cli

创建uni-app

使用正式版(对应HBuilderX最新正式版)

vue create -p dcloudio/uni-preset-vue my-project

使用alpha版(对应HBuilderX最新alpha版)

vue create -p dcloudio/uni-preset-vue#alpha my-alpha-project

此时,会提示选择项目模板,初次体验建议选择 hello uni-app 项目模板,如下所示:

 用Vue CLI创建uni-app,摆脱HBuilder,npm命令行运行及发布 经验总结

自定义模板

选择自定义模板时,需要填写 uni-app 模板地址,这个地址其实就是托管在云端的仓库地址。以 GitHub 为例,地址格式为 userName/repositoryName,如 dcloudio/uni-template-picture 就是下载图片模板。

更多支持的下载方式,可参考这个插件的说明:download-git-repo

修改依赖为指定版本

  1. 查看 HBuilderX 对应的 NPM 依赖版本: 打开 NPM版本记录,版本号 2.0.0- 后面是与 HBuilderX 对应的版本号且小版本不会超过9,比如 HBuilderX 2.7.5.20200518 对应的版本号 2.0.0-27520200518001,2.0.0-271420200618 对应的为 2.0.0-27920200618002。

  2. 批量修改 package.json 中 uni 相关依赖为指定的版本号(去掉版本号前面 ^)。

  3. 对于有变化的依赖进行增删,提示不存指定版本的依赖可以保留原始版本或者删除,运行时提示缺少的依赖自行安装。

运行、发布uni-app

npm run dev:%PLATFORM% npm run build:%PLATFORM%

%PLATFORM% 可取值如下:

平台
app-plusapp平台生成打包资源(支持npm run build:app-plus,可用于持续集成。不支持run,运行调试仍需在HBuilderX中操作)
h5H5
mp-alipay支付宝小程序
mp-baidu百度小程序
mp-weixin微信小程序
mp-toutiao字节跳动小程序
mp-qqqq 小程序
mp-360360 小程序
quickapp-webview快应用(webview)
quickapp-webview-union快应用联盟
quickapp-webview-huawei快应用华为

可以自定义更多条件编译平台,比如钉钉小程序,参考package.json文档


未经允许不得转载:w3h5 » 用Vue CLI创建uni-app,摆脱HBuilder,npm命令行运行及发布

赞 (0)
分享到: +

评论 沙发

换个身份

  • 昵称 (必填)
  • 邮箱 (选填)