VSCode执行yarn报错:无法加载文件 C:\Users\Admin\AppData\Roaming\npm\yarn.ps1的解决方法

VSCode 执行 yarn 命令时报错:

无法加载文件 C:\Users\Admin\AppData\Roaming\npm\yarn.ps1,因为在此系统中禁止执行脚本。有关详细信息,请参阅 "get-help about_signing"。
所在位置 行:1 字符: 5
+ yarn <<<< 
    + CategoryInfo          : NotSpecified: (:) [], PSSecurityException
    + FullyQualifiedErrorId : RuntimeException

解决方法:

以管理员身份运行 VSCode ,powershell 执行如下命令:

set-ExecutionPolicy RemoteSigned

power shell执行策略(ExecutionPolicy)说明

#查看执行策略
get-ExecutionPolicy

#更新执行策略
Set-ExecutionPolicy <policy-name>

# policy-name 可能的值
Unrestricted(不受限制)、RemoteSigned(远程签名)、AllSigned(所有签名)、Restricted(受限制的)、Default(默认值)、Bypass(绕开)、Undefined

#将 ExecutionPolicy 改为 Unrestricted ,可以运行未签名的脚本
Set-ExecutionPolicy Unrestricted

#查询详细策略
get-help about_Execution_Policise

如果还是报错,检查一下 yarn 有没有安装。

全局安装 yarn :

npm i yarn -g


未经允许不得转载:w3h5 » VSCode执行yarn报错:无法加载文件 C:\Users\Admin\AppData\Roaming\npm\yarn.ps1的解决方法

赞 (1)
分享到: +

评论 沙发

换个身份

  • 昵称 (必填)
  • 邮箱 (选填)